summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-06-25 18:34:41 +0300
committerGitHub <noreply@github.com>2021-06-25 18:34:41 +0300
commitc6b1c6ba7a01b7987d65d61c262c44c320193108 (patch)
treec31fba338a65c86741b16e061d66e0e060e3b768 /meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
parente7436234669703196c5ed56f33050d2dc19127cd (diff)
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
downloadopenbmc-c6b1c6ba7a01b7987d65d61c262c44c320193108.tar.xz
Merge pull request #68 from Intel-BMC/update2021-0.571-0.57
Update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 72f49a5bc..630dc6bcd 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -8,9 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
inherit autotools pkgconfig
inherit python3native
-inherit phosphor-networkd-rev
inherit systemd
+SRC_URI += "git://github.com/openbmc/phosphor-networkd"
+SRCREV = "de433b74ec5bce22043ea44c55e83d9be3dc5372"
DEPENDS += "systemd"
DEPENDS += "autoconf-archive-native"
@@ -22,10 +23,14 @@ DEPENDS += "libnl"
DEPENDS += "stdplus"
DEPENDS += "nlohmann-json"
-PACKAGECONFIG ??= "uboot-env"
+PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra"
UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
+PACKAGECONFIG[default-link-local-autoconf] = "--enable-link-local-autoconfiguration,--disable-link-local-autoconfiguration,,"
+PACKAGECONFIG[default-ipv6-accept-ra] = "--enable-ipv6-accept-ra,--disable-ipv6-accept-ra,,"
+PACKAGECONFIG[nic-ethtool] = "--enable-nic-ethtool,--disable-nic-ethtool,,"
+PACKAGECONFIG[sync-mac] = "--enable-sync-mac,--disable-sync-mac,,"
S = "${WORKDIR}/git"