summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/network
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/network
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/network')
-rw-r--r--meta-phosphor/recipes-phosphor/network/inarp.bb18
-rw-r--r--meta-phosphor/recipes-phosphor/network/inarp/inarp.service10
-rw-r--r--meta-phosphor/recipes-phosphor/network/network.bb27
-rw-r--r--meta-phosphor/recipes-phosphor/network/network/xyz.openbmc_project.Network.service13
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-snmp/xyz.openbmc_project.Network.SNMP.service13
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb31
6 files changed, 112 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/inarp.bb b/meta-phosphor/recipes-phosphor/network/inarp.bb
new file mode 100644
index 000000000..90969c248
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/inarp.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Inverse ARP daemon"
+DESCRIPTION = "Daemon to respond to Inverse-ARP requests"
+HOMEPAGE = "http://github.com/openbmc/inarp"
+PR = "r1"
+
+inherit autotools
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+DEPENDS += "autoconf-archive-native"
+RDEPENDS_${PN} += "network"
+
+SRC_URI += "git://github.com/openbmc/inarp"
+SRCREV = "6e296617f041d7665b2540151646af452088482c"
+
+S = "${WORKDIR}/git"
+
+exec_prefix="/usr/local"
diff --git a/meta-phosphor/recipes-phosphor/network/inarp/inarp.service b/meta-phosphor/recipes-phosphor/network/inarp/inarp.service
new file mode 100644
index 000000000..5d26559f0
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/inarp/inarp.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Phosphor Inverse ARP
+
+[Service]
+ExecStart=/usr/bin/env inarp
+SyslogIdentifier=inarp
+Restart=always
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/network/network.bb b/meta-phosphor/recipes-phosphor/network/network.bb
new file mode 100644
index 000000000..3170d56ee
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/network.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Network DBUS object"
+DESCRIPTION = "Network DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit obmc-phosphor-license
+inherit obmc-phosphor-dbus-service
+inherit phosphor-networkd-rev
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.service"
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "libnl"
+
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "phosphor-logging"
+RDEPENDS_${PN} += "libnl"
+RDEPENDS_${PN} += "libnl-genl"
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/network/network/xyz.openbmc_project.Network.service b/meta-phosphor/recipes-phosphor/network/network/xyz.openbmc_project.Network.service
new file mode 100644
index 000000000..b9f7da728
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/network/xyz.openbmc_project.Network.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Phosphor Network Manager
+After=obmc-mapper.target
+
+[Service]
+ExecStart=/usr/bin/env phosphor-network-manager
+SyslogIdentifier=phosphor-network-manager
+Restart=always
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-snmp/xyz.openbmc_project.Network.SNMP.service b/meta-phosphor/recipes-phosphor/network/phosphor-snmp/xyz.openbmc_project.Network.SNMP.service
new file mode 100644
index 000000000..f5a1d7274
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-snmp/xyz.openbmc_project.Network.SNMP.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Phosphor SNMP conf Manager
+After=obmc-mapper.target
+
+[Service]
+ExecStart=/usr/bin/env phosphor-network-snmpconf
+SyslogIdentifier=phosphor-network-snmpconf
+Restart=always
+Type=dbus
+BusName=xyz.openbmc_project.Network.SNMP
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb
new file mode 100644
index 000000000..7818579f0
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "SNMP Manager Configuration"
+DESCRIPTION = "SNMP Manager Configuration."
+HOMEPAGE = "http://github.com/openbmc/phosphor-snmp"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+inherit autotools pkgconfig
+inherit pythonnative
+inherit obmc-phosphor-dbus-service
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI += "git://github.com/openbmc/phosphor-snmp"
+SRCREV = "f4ecf883389f5d9d7ebf635d62b20b91ef72e048"
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.SNMP.service"
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "net-snmp"
+
+RDEPENDS_${PN} += "libsystemd"
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+RDEPENDS_${PN} += "phosphor-logging"
+RDEPENDS_${PN} += "net-snmp-libs"
+
+S = "${WORKDIR}/git"