summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
new file mode 100644
index 000000000..783ce40ce
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor OpenBMC - YAML Providers"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+# This is a packagegroup in name and principle but we do not want to inherit
+# from packagegroup.bbclass. The point of this packagegroup is to get the
+# sysroot populated with YAML files from the DEPENDS packages and if we inherit
+# the packagegroup bbclass this doesn't happen, because that bbclass `deltask`
+# a number that are required.
+# inherit packagegroup
+
+OBMC_YAML_PROVIDER_RECIPES += " \
+ phosphor-led-manager-yaml-provider \
+ phosphor-software-manager-yaml-provider \
+ "
+
+DEPENDS = "${OBMC_YAML_PROVIDER_RECIPES}"
+RDEPENDS_${PN} = "${OBMC_YAML_PROVIDER_RECIPES}"