summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index d8dcd0d2c..1c07ad59d 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -4,6 +4,7 @@ PR = "r1"
PV = "1.0+git${SRCPV}"
inherit meson pkgconfig
+inherit systemd
require pldm.inc
@@ -15,7 +16,33 @@ DEPENDS += "cli11"
S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} += "pldmd.service"
+SYSTEMD_SERVICE_${PN} += "pldmSoftPowerOff.service"
+
EXTRA_OEMESON = " \
-Dtests=disabled \
-Doem-ibm=disabled \
"
+
+# Install pldmSoftPowerOff.service in correct targets
+pkg_postinst_${PN} () {
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN} () {
+
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ rm $LINK
+}