summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 00:45:46 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 00:45:46 +0300
commit930df2e58b9725756edbccf99fd4979026fc28fd (patch)
tree8c5fa9f20219e9bc4580bb18e03b8dd8043a9a4f /meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
parent7c5f8839ec3d71a2170b8f3514a16a67c69d1c7c (diff)
parent377d8f40e88eeb9ccb1321590a3af3c2caa94dda (diff)
downloadopenbmc-930df2e58b9725756edbccf99fd4979026fc28fd.tar.xz
Merge tag '0.35' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm/pldm_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 1c07ad59d..e6ac942bd 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -32,6 +32,11 @@ pkg_postinst_${PN} () {
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
+ mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
+ TARGET="../pldmSoftPowerOff.service"
+ ln -s $TARGET $LINK
+
mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
@@ -43,6 +48,9 @@ pkg_prerm_${PN} () {
LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
+ rm $LINK
+
LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
rm $LINK
}