summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/pldm
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:19:32 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:19:32 +0300
commit901ced0812b458fdc599fe40b0a4233d422d6df9 (patch)
treeb0918e0606da0b1925b5fc9aba5e065e0a5a2f0e /meta-phosphor/recipes-phosphor/pldm
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
parent459d47e59bfb3f80542f17c7eb54ba1f6c1a44f3 (diff)
downloadopenbmc-901ced0812b458fdc599fe40b0a4233d422d6df9.tar.xz
Merge tag '0.77' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/pldm')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb12
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm.inc b/meta-phosphor/recipes-phosphor/pldm/pldm.inc
index 68b4ece2a..40b959a75 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm.inc
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/pldm"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://github.com/openbmc/pldm"
-SRCREV = "430aaee5013789862de586473b43d2191d492a41"
+SRCREV = "be06bc920c007254d5ffd52adb9d2ba4a111c20e"
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index bcf1bed23..4c9cbc983 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -28,22 +28,22 @@ EXTRA_OEMESON = " \
# Install pldmSoftPowerOff.service in correct targets
pkg_postinst:${PN} () {
- mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires
- LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
- mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
- LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
}
pkg_prerm:${PN} () {
- LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
rm $LINK
}