summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb
index 77df3acf5..01ddecbe0 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links-monitor.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch
-RDEPENDS_${PN}-monitor += "phosphor-power-monitor"
+RDEPENDS:${PN}-monitor += "phosphor-power-monitor"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/multi-user.target.requires
[ -z "${OBMC_POWER_SUPPLY_INSTANCES}" ] && echo "No power supply instance defined" && exit 1
@@ -23,7 +23,7 @@ pkg_postinst_${PN}() {
done
}
-pkg_prerm_${PN}() {
+pkg_prerm:${PN}() {
[ -z "${OBMC_POWER_SUPPLY_INSTANCES}" ] && echo "No power supply instance defined" && exit 1
for inst in ${OBMC_POWER_SUPPLY_INSTANCES}; do