summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-10-21 05:39:07 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-30 16:24:17 +0300
commit50ab1ac76c1870f27682d892df82b35369535b55 (patch)
treeddeb65d0e8b4bd34190c9854bf51c35f4ddd4ddd /meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
parent28095f1ce1fd809d57d6139c17778fa0aab51336 (diff)
downloadopenbmc-50ab1ac76c1870f27682d892df82b35369535b55.tar.xz
Add phosphor-power recipe
There was witherspoon-fault-analysis recipe in meta-ibm. Now the repo becomes a generic one, phosphor-power, add the recipe in meta-phosphor. Tested: Verify the build `bitbake phosphor-power` succeeds. With changes in meta-ibm/meta-witherspoon, verify phosphor-power is built correctly and the services are installed. (From meta-phosphor rev: 4d8175e674b521669822da61d09b338f391b38fa) Change-Id: I4e30bba75a0883c4e431c56a10eef7917b5c46c8 Signed-off-by: Lei YU <mine260309@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
new file mode 100644
index 000000000..b66c107f4
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Phosphor Power services and utilities"
+DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
+voltage regulators, and analyzes power devices for faults"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
+inherit pythonnative
+
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+
+# TODO: in future when openpower-dbus-interfaces is removed from
+# phosphor-power, remove the dependency here.
+DEPENDS += " \
+ phosphor-logging \
+ openpower-dbus-interfaces \
+ sdbus++-native \
+ sdeventplus \
+ nlohmann-json \
+ "
+
+SEQ_MONITOR_SVC = "pseq-monitor.service"
+SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
+PSU_MONITOR_TMPL = "power-supply-monitor@.service"
+SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"