summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/power
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2019-12-21 00:54:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-30 04:47:35 +0300
commit75ecde514a692d6812806a0286faaa2b989680e2 (patch)
tree07d44c320ba67cc36944bf093f37da2fb64c479d /meta-phosphor/recipes-phosphor/power
parent7036eea7da4a199d7edc9130a2480ebd6403c1d5 (diff)
downloadopenbmc-75ecde514a692d6812806a0286faaa2b989680e2.tar.xz
phosphor-power: Add phosphor-regulators-monitor services
Add the phosphor-regulators monitor services that perform method calls to phosphor-regulators to enable or disable monitoring of the regulators. The enable service should be started after power sequencing begins during a poweron and the disable service startsp immediately at a poweroff to halt monitoring Tested: Monitoring started after power sequencing services and the chassis is on Monitoring disabled immediately at poweroff (From meta-phosphor rev: a51bc302c63971fd30798e7a167a24303843489e) Change-Id: I1da591b9d895d24ce351867aa4eaa9039a13acbf Signed-off-by: Matthew Barth <msbarth@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/power')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power.inc b/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
index 1a98ac999..aee6c9fcf 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-power"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-power"
-SRCREV = "ec16128c008de889c1290241c56847b36ffdec49"
+SRCREV = "01bc612007c0248745a90f857fb9f72ba1586407"
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
index b7bcfd352..cf853d254 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
@@ -49,11 +49,13 @@ PSU_MONITOR_TMPL = "power-supply-monitor@.service"
PSU_MONITOR_SVC = "phosphor-psu-monitor.service"
REGS_SVC = "phosphor-regulators.service"
REGS_CONF_SVC = "phosphor-regulators-config.service"
+REGS_MON_ENA_SVC = "phosphor-regulators-monitor-enable.service"
+REGS_MON_DIS_SVC = "phosphor-regulators-monitor-disable.service"
SYSTEMD_SERVICE_${PN}-sequencer = "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
SYSTEMD_SERVICE_${PN}-monitor = "${PSU_MONITOR_TMPL}"
SYSTEMD_SERVICE_${PN}-psu-monitor = "${PSU_MONITOR_SVC}"
-SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC} ${REGS_CONF_SVC}"
+SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC} ${REGS_CONF_SVC} ${REGS_MON_ENA_SVC} ${REGS_MON_DIS_SVC}"
# TODO: cold-redundancy is not installed in the repo yet