summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/power
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2020-03-06 05:26:57 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-18 05:44:10 +0300
commit6ac94e2b63e409402d8fb4627427c10df0e050ab (patch)
treec46e11540efe9dd160d758468656a09de0abd49a /meta-phosphor/recipes-phosphor/power
parent017f9422dee36ac1e468ed1036ffec6f4a19d497 (diff)
downloadopenbmc-6ac94e2b63e409402d8fb4627427c10df0e050ab.tar.xz
phosphor-power: use python3
The python scripts in this repo supports both python2 and python3. Use python3 now since python2 is EOL. Tested: Verify the recipe builds fine with sdbusplus python2 or python3. (From meta-phosphor rev: 404e16319c6f9afae5a055c570e24e1a8cfa6e05) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: Ic63d65a4ad40db646baa2eab92941dfde850ffe1 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/power')
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power.inc b/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
index 53285039d..7cef5b368 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-power"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-power"
-SRCREV = "a57e08144d76456cfe14859bd6e5c096f9a9ad59"
+SRCREV = "43082e70b20692017c279c4448c8f05066ce3805"
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
index 0a9c709d9..1102b574c 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power_git.bb
@@ -7,7 +7,7 @@ PV = "1.0+git${SRCPV}"
inherit meson
inherit pkgconfig
inherit systemd
-inherit pythonnative
+inherit python3native
require ${PN}.inc