summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
diff options
context:
space:
mode:
authorVijay Khemka <vijaykhemka@fb.com>2020-10-09 02:36:28 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-14 00:45:03 +0300
commitfa9f2ad1ffd8993ad1253565b51938e9b2822f1a (patch)
tree24fe66d8d6ee74c2b45dd52a3b0231bc5bf3a4dc /meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
parentf7d4b719956293b37596476492ad6191787e6cf8 (diff)
downloadopenbmc-fa9f2ad1ffd8993ad1253565b51938e9b2822f1a.tar.xz
meta-phosphor: sensor: Add virtual sensor recipe
Added new recipe for virtual sensor application which creates a new sensor based on given sensor data as a paraemeter in config file. (From meta-phosphor rev: 55cd70545e1c65bdddc808a6034408f054d45882) Change-Id: I087abee6869925d2aee77e02941e69eb01ac3266 Signed-off-by: Vijay Khemka <vijaykhemka@fb.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
new file mode 100644
index 000000000..fe65fa218
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-virtual-sensor_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Virtual Sensors"
+DESCRIPTION = "virtual sensors created from existing sensors and config data"
+HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
+
+inherit meson pkgconfig
+inherit systemd
+
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "nlohmann-json"
+DEPENDS += "exprtk"
+
+SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
+SRCREV = "92d648b29beeee64b74f6777a4470d7dfcb3289a"
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"