summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/settings
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-07-09 23:59:54 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-07 03:20:22 +0300
commitff92bb65d956b7936b89f41d8ca7d0bce2e54205 (patch)
treec0d3d32d05c0faa44593312feaffe0d94b44e8b5 /meta-phosphor/recipes-phosphor/settings
parentef7abcca9d0c9dcb08e19675b76d1fb722ade35d (diff)
downloadopenbmc-ff92bb65d956b7936b89f41d8ca7d0bce2e54205.tar.xz
meta-phosphor: drop feature check wrappers
These pointless wrappers don't do anything other than obfuscate intent to readers that have experience with bitbake metadata. (From meta-phosphor rev: 536cee986517bf14226feb2f412928bc1904f950) Change-Id: I92b12b6d675acb65d67f442c6331560cb20c88e6 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
index 0766005cc..5fcaa5902 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-manager_git.bb
@@ -17,7 +17,7 @@ DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "autoconf-archive-native"
DEPENDS += "virtual/phosphor-settings-defaults"
-DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native', '', d)}"
DEPENDS += "sdbusplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
@@ -47,7 +47,7 @@ python do_merge_settings () {
cmd.append(os.path.join(workdir, 'merge_settings.py'))
cmd.append(os.path.join(settingsdir, 'defaults.yaml'))
# Used for any settings from the MRW
- use_mrw = df_enabled(d, 'obmc-mrw', 'true')
+ use_mrw = bb.utils.contains('DISTRO_FEATURES', 'obmc-mrw', 'true', '', d)
if (use_mrw == 'true'):
cmd.append(os.path.join(settingsdir, 'mrw-settings.override.yaml'))