summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/skeleton
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/skeleton
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/skeleton')
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb21
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json3
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
new file mode 100644
index 000000000..b02b83234
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
@@ -0,0 +1,21 @@
+SUMMARY = "OpenBMC gdbus library"
+DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
+methods and the GDBUS skeleton code for the org.openbmc DBUS API."
+PR = "r1"
+
+inherit skeleton
+inherit pkgconfig
+
+DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
+
+SKELETON_DIR = "libopenbmc_intf"
+
+SRC_URI += "file://gpio_defs.json"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+
+ install -d ${D}${sysconfdir}/default/obmc/gpio/
+ install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
+}
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..6e4ef9ff9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,3 @@
+{
+ "_comments": "This file should be overridden with one from the machine layer."
+}