summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
commit9600a7403ba2848c8751280077503a3e0f2f3481 (patch)
tree996726918f255cc9686dec34628fab410ac8f550 /meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
parentb11bad1ba28f79c08266efb9cc265d89103e5939 (diff)
parent5ec7af7413906b500cce396255bde69c9770f6d8 (diff)
downloadopenbmc-9600a7403ba2848c8751280077503a3e0f2f3481.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
new file mode 100644
index 000000000..0bbf0e9a9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Phosphor post code manager"
+DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
+interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
+in a file under /var/lib for history."
+
+SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
+SRCREV = "655837973feb51da3767f5f246ec198877900b0b"
+
+S = "${WORKDIR}/git"
+
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit cmake pkgconfig systemd
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service"
+
+DEPENDS += " \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ "