summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-10 06:19:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 05:41:37 +0300
commit186155f6368a3f8cb86cad684b18e2e280f9ca6c (patch)
tree760223f84a276cb1235f57ff9a91df10a4fd1721 /meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb
parenta2ff11e9589a96f70e8110555dd4aa81a071aba4 (diff)
downloadopenbmc-186155f6368a3f8cb86cad684b18e2e280f9ca6c.tar.xz
meta-phosphor: system: obmc-control-bmc: rename as git
obmc-control-bmc.bb inherits skeleton-gdbus, which is git-based. (From meta-phosphor rev: 1a652adba18a372f4766776bd9fd88f2483ba75d) Change-Id: I6352fc2fdc8eb1044e60c84e6b60b8326bcdc76b Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb
new file mode 100644
index 000000000..7044f7923
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "OpenBMC org.openbmc.control.Bmc example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.control.Bmc DBUS API. \
+org.openbmc.control.Bmc provides APIs for functions like resetting the BMC."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+SKELETON_DIR = "bmcctl"
+
+FMT = "org.openbmc.control.Bmc@{0}.service"
+DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_BMC_INSTANCES')}"