summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/system
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-22 23:30:00 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-26 19:15:19 +0300
commit060ad3ff7fcc30aff78a9e504efee9d8fa0d4526 (patch)
tree877dd0f9de6316140d0749ef598599df014e2a6d /meta-phosphor/recipes-phosphor/system
parentef38215c4c61a187cfc2e4e52bb467d15257d340 (diff)
downloadopenbmc-060ad3ff7fcc30aff78a9e504efee9d8fa0d4526.tar.xz
treewide: remove obmc-system-mgmt feature
Every machine layer treats 'system-management' as either part of a package-group or removes the feature. The sample implementation in meta-phosphor is a do-nothing shell script (and up until recently was a Python script). There appears to be no useful purpose to this feature as a stand-alone concept, so remove it. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20ca1fa8ff3cb01cac2d07d4ded84e0769e4514b
Diffstat (limited to 'meta-phosphor/recipes-phosphor/system')
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb18
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.service10
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.sh24
3 files changed, 0 insertions, 52 deletions
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb b/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb
deleted file mode 100644
index 06eb55ec2..000000000
--- a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "Phosphor OpenBMC System Management"
-DESCRIPTION = "Phosphor OpenBMC system management reference implementation."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-dbus-service
-
-PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES:${PN} += "virtual-obmc-system-mgmt"
-
-S = "${WORKDIR}"
-SRC_URI += "file://${BPN}.sh"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${bindir}/${BPN}
-}
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.service b/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.service
deleted file mode 100644
index 246d985ba..000000000
--- a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Phosphor System Manager
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env obmc-phosphor-sysd
-SyslogIdentifier=obmc-phosphor-sysd
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.sh b/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.sh
deleted file mode 100644
index 95488d04d..000000000
--- a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd/obmc-phosphor-sysd.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-# Contributors Listed Below - COPYRIGHT 2015
-# [+] International Business Machines Corp.
-#
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
-# implied. See the License for the specific language governing
-# permissions and limitations under the License.
-
-echo "obmc-phosphor-sysd starting..."
-
-while true
-do
- sleep 60
-done