summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
new file mode 100644
index 000000000..feff0045e
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/telemetry/telemetry_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Telemetry service"
+DESCRIPTION = "Middleware between Redfish Telemetry Service and dbus-sensors"
+HOMEPAGE = "https://github.com/openbmc/telemetry"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "git://github.com/openbmc/telemetry"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "0e29f4392264a9646834583ddd5eaadc25fab20b"
+
+S = "${WORKDIR}/git"
+
+inherit meson
+inherit systemd
+
+DEPENDS = "boost \
+ gtest \
+ nlohmann-json \
+ phosphor-logging \
+ sdbusplus \
+ systemd"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Telemetry.service"
+EXTRA_OEMESON = "-Dbuildtest=false"
+