summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/video
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-08-06 17:16:53 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 00:56:33 +0300
commit12fc939cde971ea2094201e48fe095c41138f4aa (patch)
tree2fc49b7224d97fc0e43011cc3d9c85eaa933d0a9 /meta-phosphor/recipes-phosphor/video
parent9b3d987c3c2facf75e1039766d31fbf31508fc19 (diff)
downloadopenbmc-12fc939cde971ea2094201e48fe095c41138f4aa.tar.xz
meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
Diffstat (limited to 'meta-phosphor/recipes-phosphor/video')
-rw-r--r--meta-phosphor/recipes-phosphor/video/fbterm_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/video/fbterm_git.bb b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
index 0c171dd3a..57e217450 100644
--- a/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
+++ b/meta-phosphor/recipes-phosphor/video/fbterm_git.bb
@@ -25,5 +25,5 @@ do_install() {
install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}/
}
-SYSTEMD_SERVICE_${PN} += "fbterm.service"
+SYSTEMD_SERVICE:${PN} += "fbterm.service"
SYSTEMD_ENVIRONMENT_FILE_${PN} += "fbterm"
diff --git a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
index 9f3e21344..62d19ec82 100644
--- a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
+++ b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
@@ -14,16 +14,16 @@ inherit systemd
DEPENDS += "autoconf-archive-native"
DEPENDS += "systemd"
-RDEPENDS_${PN} += "fbterm"
+RDEPENDS:${PN} += "fbterm"
SRCREV = "26ac7f7bd6af52db63451d3633bcf1b167eea3d1"
PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "uart-render-controller.service"
+SYSTEMD_SERVICE:${PN} += "uart-render-controller.service"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/
}