summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
committerEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
commita75bff085ba9443315222231c42692745e5781e9 (patch)
treee1aa422babae0dffc866af076a0274ff26c2c4b2 /meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
parent3e809d0d5cf96c18c5720d1b6b3b53e9f4c0cfae (diff)
parent6d4bcf0a75b2a6055055c9ad8ed6b93599082385 (diff)
downloadopenbmc-a75bff085ba9443315222231c42692745e5781e9.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
index 7f44590ed..906f6654a 100644
--- a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
+++ b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
@@ -6,25 +6,27 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit obmc-phosphor-dbus-service
RPROVIDES_${PN} += "virtual/obmc-watchdog"
PROVIDES += "virtual/obmc-watchdog"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "cli11"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
-RDEPENDS_${PN} += "libsystemd"
-RDEPENDS_${PN} += "phosphor-logging"
+DEPENDS += "systemd"
SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
-SRCREV = "b93377104292de0f94087c0cbb79d4d6d8516b84"
+SRCREV = "26eef26c97beec18d0f96fd1cd792229caded542"
S = "${WORKDIR}/git"
+EXTRA_OEMESON = " \
+ -Dtests=disabled \
+ "
+
# Copies config file having arguments for host watchdog
SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"