summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-15 23:52:23 +0300
committerEd Tanous <ed@tanous.net>2021-06-18 21:13:32 +0300
commit28d315377d2a902e2d3691159411c18a2ce64a66 (patch)
tree31d6647c07fa3f824505b82a1c297a74b43e47af /meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
parentae9ca4d1babde7ac0cfcbc9b9d0dda95d0e25832 (diff)
downloadopenbmc-28d315377d2a902e2d3691159411c18a2ce64a66.tar.xz
webui-vue: Add a task to find node licences
Many open source licenses require the module and license to be identified in the image. Yocto provides this capability for the modules that it includes; however, this doesn't cover the modules that npm includes during the build of webui-vue. This change adds a new module named 'nlf' to find and create a summary of the nodes and their licenses. The nlf recipe file was generated automatically with: devtool add 'npm://registry.npmjs.org;package=nlf;version=latest' Then a new 'find_node_licenses' task in the webui-vue recipe uses 'nlf-native' to create a summary and save it to the webui-vue license directory where Yocto stores its license info. Tested: Confirmed that the nlf recipe builds. Confirmed that the 'find_node_licenses' task runs and that the license summary is available under 'build/tmp/deploy/licenses/webui-vue/node-licenses' Change-Id: Ia53f6e463db6966f450be2a37dc82a3c5e3f76c1 Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index 5b8dec5fe..546c39ae4 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/openbmc/webui-vue.git"
SRCREV = "3f9cfa2c2491cc060ea57787660e918e4a7ee7e5"
S = "${WORKDIR}/git"
-DEPENDS_prepend = "nodejs-native "
+DEPENDS_prepend = "nodejs-native nlf-native "
# allarch is required because the files this recipe produces (html and
# javascript) are valid for any target, regardless of architecture. The allarch
@@ -45,3 +45,9 @@ do_install () {
find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
}
+do_find_node_licenses() {
+ cd ${S}
+ nlf -s detail > ${LICENSE_DIRECTORY}/${PN}/node-licenses
+}
+
+addtask find_node_licenses after do_compile before do_build