summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-11-06 17:39:44 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-11-13 02:10:59 +0300
commited869752dc9ee901a6288578b1023264066137c7 (patch)
treecd745d31cab64160348b1af4178af0a2e1d1eb40 /meta-phosphor/recipes-phosphor
parent209ed52b727ba1d039cecaf0c66e1b79822b70cc (diff)
downloadopenbmc-ed869752dc9ee901a6288578b1023264066137c7.tar.xz
entity-manager: add support for dbus activation
Add the dependency on dbus-1, which EM needs for some path variables in its pkg-config file, and update to handle the additional dbus activation unit file artifact. (From meta-phosphor rev: 2a141b6951e19f67d94f7f1983c0115a909aef56) Change-Id: I982635578036c2c8219c0446213e52a80d439e38 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index 31bbea13e..2fc69ca90 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -10,6 +10,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
DEPENDS = "boost \
+ dbus \
nlohmann-json \
sdbusplus \
valijson"
@@ -32,6 +33,9 @@ do_install_append() {
install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
}
+FILES_${PN} += " \
+ ${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \
+ "
FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"