summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-25 22:40:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-12 23:10:16 +0300
commit57e15b1d5cf7749e6bd01c3ef484689f4191d51e (patch)
treeb3c83e9288860ba87c90ca39437989a5065cae9f /meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
parentdfcf32d1c2b9a3de7a0aaeddfe0aba2c1ec06a16 (diff)
downloadopenbmc-57e15b1d5cf7749e6bd01c3ef484689f4191d51e.tar.xz
meta-phosphor: use systemd_system_unitdir
This variable was added to bitbake.conf so lets use it. Using it is best pratice and enables things like alternative base_libdir paths. Change-Id: I181d12e02ca7918614dacec68bd8e033932eb0ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb')
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
index 5fcfeea17..596c1824f 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -49,8 +49,8 @@ do_install_append() {
sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
}
inherit update-rc.d systemd