summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend')
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index 16add36d8..ce5d7994b 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -1,13 +1,26 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://10-nice.conf"
+PACKAGECONFIG_remove = "\
+ ${@bb.utils.contains('MACHINE_FEATURES', 'hw-rng', \
+ 'libjitterentropy', '', d)}\
+ "
+
inherit systemd
FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
do_install_append() {
+
+ # When using systemd and using libjitterentropy, install a config
+ # which runs rngd at a 'nice' priority. libjitterentropy uses a
+ # lot of CPU early on in the boot process and makes the whole boot
+ # go slower.
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system/rngd.service.d
- install -m 644 ${WORKDIR}/10-nice.conf ${D}${systemd_unitdir}/system/rngd.service.d
+ if ${@bb.utils.contains('PACKAGECONFIG', 'libjitterentropy', 'true', 'false', d)}; then
+ install -d ${D}${systemd_unitdir}/system/rngd.service.d
+ install -m 644 ${WORKDIR}/10-nice.conf \
+ ${D}${systemd_unitdir}/system/rngd.service.d
+ fi
fi
}