summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-11-03 17:16:37 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-11-03 23:31:13 +0300
commit56a8292be03a7cb27f3b3ad762f4779e7e5ff47d (patch)
tree46171677f836a8b8002bd9c49ff677858f4b98b9 /meta-phosphor/recipes-support
parentbbbd5f468dc9c43b203cac3775f6c1b782ca7cba (diff)
downloadopenbmc-56a8292be03a7cb27f3b3ad762f4779e7e5ff47d.tar.xz
Revert "Move context and coroutine"
This reverts commit 6be1787fdc13405fa9daa6755c28534bbcaa7458. openbmc/openbmc#3720 tracks the issue we've been having with the latest poky update. For now we're going to have to revert it which means we need to go back to handling the older boost. Lets revert this so we go back to not minimizing our boost library which will cause a bit larger library in flash but allow us to support both the old and new boost packaging. (From meta-phosphor rev: 3ee1f9df23ab04871297676c265dfcf0a8db38f4) Change-Id: Ib45de998931142ea74dffddafd960b7513717a18 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index fabb7f55e..b614346af 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -1,10 +1,12 @@
#This is largely to improve our build times by not building or installing
-#modules that OpenBMC does not use by our coding standard. Chrono and Thread
-#should not be relied directly, but are required dependencies of context and
-#coroutine at build time. See the relevant portion of the openbmc coding
-#standard with regards to boost libraries
+#modules that OpenBMC does not use by our coding standard. Another thing to
+#note is that for most targets, coroutine and context libraries are also added
+#with a BOOST_LIBS_append_<platform> for most targets. Chrono/Thread should not
+#be relied directly, but are required dependencies of context and coroutine.
+#See the relevant portion of the openbmc coding standard with regards to boost
+#libraries
#
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
-BOOST_LIBS_openbmc-phosphor = "chrono context coroutine thread"
+#BOOST_LIBS_openbmc-phosphor = "chrono thread"