summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2018-04-11 06:10:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-18 23:30:32 +0300
commit1065559cfc44d811a8bce3a256df48494519becc (patch)
tree5f2d16b743c08ea21460fd55d02242eaad898bfa /meta-phosphor
parentba6e2887d56d82fa5516c4b282c0a26769e3d4fd (diff)
downloadopenbmc-1065559cfc44d811a8bce3a256df48494519becc.tar.xz
meta-romulus: Add id-button.bb
This recipe adds the function to assert/deassert identify LED Group when the ID button is pressed: 1. Add phosphor-gpio-monitor for the ID button GPIO key; 2. Start id-button-pressed.service when the key is pressed; 3. The service starts a script to check the identify LED group state, and assert or de-assert it. Tested: Assert/De-assert identify LED group by pressing the ID button on Romulus. Change-Id: I782dbc15563a313418aa90bee1f48fc97a6d25fb Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-monitor@.service2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-monitor@.service b/meta-phosphor/common/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-monitor@.service
index a9644a74d..63f88a1f5 100644
--- a/meta-phosphor/common/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-monitor@.service
+++ b/meta-phosphor/common/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-gpio-monitor@.service
@@ -4,5 +4,5 @@ Description=Phosphor GPIO %I monitor
[Service]
Restart=no
EnvironmentFile={envfiledir}/obmc/gpio/%I
-ExecStart=/usr/bin/env phosphor-gpio-monitor --path=${{DEVPATH}} --key=${{KEY}} --polarity=${{POLARITY}} --target=${{TARGET}}
+ExecStart=/usr/bin/env phosphor-gpio-monitor --path=${{DEVPATH}} --key=${{KEY}} --polarity=${{POLARITY}} --target=${{TARGET}} --continue=${{CONTINUE}}
SyslogIdentifier=phosphor-gpio-monitor