summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-01-29 03:42:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-01-30 19:59:20 +0300
commit59099335a6ac2861fb664df34c3ac4b4bf39467d (patch)
treee6eddb658fa2849a63f2f3a003dd1d676769a1fd /meta-phosphor
parentcf285424e1a4e22535a3fc1259f78252be1709d2 (diff)
downloadopenbmc-59099335a6ac2861fb664df34c3ac4b4bf39467d.tar.xz
Revert "run soft off in quiesce"
This reverts commit 284d56bb877be545f59cf10883d28a37f306fc5b. Testing has uncovered some corner cases where the host is in a good enough state to respond to the initial shutdown request, but not in a good enough state to actually shut itself down. This results in the quiesce operation hitting the 2 hour timeout that is used in this scenario. 2 hours to reach a quiesce state is not acceptable. This is going to take some more design and discussion. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I45a39879da6e7af8c573a1d1d2577f98579df6ee
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/pldm/pldm_git.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index e6ac942bd..1c07ad59d 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -32,11 +32,6 @@ pkg_postinst_${PN} () {
TARGET="../pldmSoftPowerOff.service"
ln -s $TARGET $LINK
- mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
- LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
- TARGET="../pldmSoftPowerOff.service"
- ln -s $TARGET $LINK
-
mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
TARGET="../pldmSoftPowerOff.service"
@@ -48,9 +43,6 @@ pkg_prerm_${PN} () {
LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.requires/pldmSoftPowerOff.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/pldmSoftPowerOff.service"
- rm $LINK
-
LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.requires/pldmSoftPowerOff.service"
rm $LINK
}