summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorGeorge Liu <liuxiwei@inspur.com>2021-10-13 10:47:46 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-15 05:26:46 +0300
commitaad4f3d4aa2b61502ceddc38d069cc79259027d8 (patch)
treee2f8f01170c646df505530c4f5340777ae5eab3f /meta-phosphor
parent4512b928d1d2dc9851c6fa12de5f89d18aa8f092 (diff)
downloadopenbmc-aad4f3d4aa2b61502ceddc38d069cc79259027d8.tar.xz
phosphor-debug-collector: Fix invalied escape sequence
There is a warning message in the phosphor-debug-collector repo when using bitbake to build image-bmc: DeprecationWarning: invalid escape sequence \W config_values = re.split('\W+', parse_value, 1) The reason is that `\W` is regarded as an escaped character, add `r` to fix it. Signed-off-by: George Liu <liuxiwei@inspur.com> Change-Id: I59836e7df9a73a01d47cd03e916f0ab1b8c2d716
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 2b7372a22..8d40965c7 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -147,7 +147,7 @@ def install_dreport_user_script(script_path, d):
bb.warn("Invalid format for config value =%s" % line)
continue
parse_value = revalue.group(0)
- config_values = re.split('\W+', parse_value, 1)
+ config_values = re.split(r'\W+', parse_value, 1)
if(len(config_values) != 2):
bb.warn("Invalid config value=%s" % parse_value)
break;