summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2018-04-20 16:54:55 +0300
committerRatan Gupta <ratagupt@in.ibm.com>2018-04-20 17:00:28 +0300
commitabf205c922186290ced31166664c3e54c62b64ec (patch)
treec46d437a2abf95d8cd080ddf115896e952638426 /meta-phosphor
parenta5d6f4072850bd3eb1466bcb403cbc9a989ac964 (diff)
downloadopenbmc-abf205c922186290ced31166664c3e54c62b64ec.tar.xz
Revert "Avahi: Don't start the avahi-daemon if dot local domain is there"
Currently this commit uses the host command which comes through bind-utils pacakge,host command and the dependent librarys taking up around 3MB space so reverting this commit. This reverts commit 8f852d2b9484202118e382a31d16e659b91789ee. Change-Id: I1d5d08f15cfd2da79435f4ee0dfe614b2e405681 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-connectivity/avahi/avahi/avahi.conf2
-rw-r--r--meta-phosphor/common/recipes-connectivity/avahi/avahi/check-avahi-pre-cond.service13
-rw-r--r--meta-phosphor/common/recipes-connectivity/avahi/avahi/check-local-domain9
-rw-r--r--meta-phosphor/common/recipes-connectivity/avahi/avahi/create-user6
-rw-r--r--meta-phosphor/common/recipes-connectivity/avahi/avahi_%.bbappend31
5 files changed, 0 insertions, 61 deletions
diff --git a/meta-phosphor/common/recipes-connectivity/avahi/avahi/avahi.conf b/meta-phosphor/common/recipes-connectivity/avahi/avahi/avahi.conf
deleted file mode 100644
index 946e267d4..000000000
--- a/meta-phosphor/common/recipes-connectivity/avahi/avahi/avahi.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-[Unit]
-ConditionPathExists=/tmp/avahi
diff --git a/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-avahi-pre-cond.service b/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-avahi-pre-cond.service
deleted file mode 100644
index f4548a75b..000000000
--- a/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-avahi-pre-cond.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Check the precondition before starting avahi
-Before=avahi-daemon.service
-
-[Service]
-RemainAfterExit=no
-Type=oneshot
-ExecStart=/usr/sbin/check-local-domain
-ExecStart=/usr/sbin/create-user
-ExecStart=/bin/touch /tmp/avahi
-
-[Install]
-WantedBy=obmc-standby.target
diff --git a/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-local-domain b/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-local-domain
deleted file mode 100644
index 978b8b6dc..000000000
--- a/meta-phosphor/common/recipes-connectivity/avahi/avahi/check-local-domain
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if !(host -t SOA local. > /dev/null 2> /dev/null); then
- # Return 1 to tell that local domain is present
- exit 1
-else
- # Return 0 to tell local domain is not being used
- exit 0
-fi
diff --git a/meta-phosphor/common/recipes-connectivity/avahi/avahi/create-user b/meta-phosphor/common/recipes-connectivity/avahi/avahi/create-user
deleted file mode 100644
index 322f1cdf3..000000000
--- a/meta-phosphor/common/recipes-connectivity/avahi/avahi/create-user
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-# Create avahi group and user
-deluser avahi ; addgroup --system avahi ; adduser --system --no-create-home --ingroup avahi avahi
-
-exit $?
diff --git a/meta-phosphor/common/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/common/recipes-connectivity/avahi/avahi_%.bbappend
deleted file mode 100644
index 0458b8245..000000000
--- a/meta-phosphor/common/recipes-connectivity/avahi/avahi_%.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://avahi.conf"
-SRC_URI += "file://check-avahi-pre-cond.service"
-SRC_URI += "file://create-user"
-SRC_URI += "file://check-local-domain"
-
-RRECOMMENDS_${PN}-daemon += "bind-utils"
-
-AVAHI_SVC = "avahi-daemon.service"
-
-AVAHI_DROPIN_DIR = "${AVAHI_SVC}.d"
-
-FILES_${PN}-daemon_append += "${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf"
-
-PACKAGE_BEFORE_PN += "${PN}-daemon-preconditions"
-
-FILES_${PN}-daemon-preconditions += "${systemd_system_unitdir}/check-avahi-pre-cond.service"
-FILES_${PN}-daemon-preconditions += "${sbindir}/create-user"
-FILES_${PN}-daemon-preconditions += "${sbindir}/check-local-domain"
-
-RRECOMMENDS_${PN}-daemon += "${PN}-daemon-preconditions"
-
-do_install_append() {
-
- mkdir -p ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}
- install -m 0755 ${WORKDIR}/avahi.conf ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf
- install -m 0755 ${WORKDIR}/check-avahi-pre-cond.service ${D}/${systemd_system_unitdir}/check-avahi-pre-cond.service
- install -m 0755 ${WORKDIR}/check-local-domain ${D}/${sbindir}/check-local-domain
- install -m 0755 ${WORKDIR}/create-user ${D}/${sbindir}/create-user
-}