summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-10-30 22:38:38 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-10-30 22:38:38 +0300
commit1e0ec55b0a3ed2a5c76d18e89d9b371da2a95b45 (patch)
tree1ebb27f0d83b2d3bf8e8527834f3fce600a17caf /meta-phosphor
parentfbdceea949784686aba75d1563f17d9116bf1f16 (diff)
parent8c8b48fe6b94c58e07eb9aec9daad4798f4fc609 (diff)
downloadopenbmc-1e0ec55b0a3ed2a5c76d18e89d9b371da2a95b45.tar.xz
Merge pull request #48 from bradbishop/btbridge
enable btbridge
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb18
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/btbridged.service8
-rw-r--r--meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/makefile.patch11
3 files changed, 37 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb
new file mode 100644
index 000000000..8572add08
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor OpenBMC BT to DBUS"
+DESCRIPTION = "Phosphor OpenBMC BT to DBUS."
+PR = "r1"
+
+inherit obmc-phosphor-sdbus-service
+inherit obmc-phosphor-c-daemon
+
+SYSTEMD_SERVICE_${PN} = "btbridged.service"
+
+inherit obmc-phosphor-host-ipmi-hw
+
+S = "${WORKDIR}/git"
+SRC_URI += "git://github.com/openbmc/btbridge file://makefile.patch"
+SRCREV="5cb9032815aa9d2866229caac4943520d5f40dd8"
+
+# This is how linux-libc-headers says to include custom uapi headers
+EXTRA_OEMAKE_append = "CFLAGS=-I${STAGING_KERNEL_DIR}/include/uapi"
+DEPENDS += "virtual/kernel"
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/btbridged.service b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/btbridged.service
new file mode 100644
index 000000000..185119ac0
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/btbridged.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Phosphor OpenBMC BT to DBUS
+
+[Service]
+ExecStart=/usr/sbin/btbridged
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/makefile.patch b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/makefile.patch
new file mode 100644
index 000000000..a2cd522b7
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/host-ipmid/btbridged/makefile.patch
@@ -0,0 +1,11 @@
+diff --git a/Makefile b/Makefile
+index 7f62be2..52e1063 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,3 +2,6 @@ all: btbridged
+
+ btbridged: btbridged.c
+ $(CC) $(CFLAGS) `pkg-config --cflags --libs libsystemd` $^ -o $@
++
++clean:
++ rm -f *.o btbridge