summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 19:53:03 +0300
committerPatrick Williams <patrick@stwcx.xyz>2017-02-02 16:43:07 +0300
commit3acb95c97521320122bdd1c735226a597c1b4363 (patch)
tree38cbbeb8183695a6e3b8ef269785d81576ab4258 /meta-phosphor
parent961df760805a18770a897998a2617f24766d0a47 (diff)
downloadopenbmc-3acb95c97521320122bdd1c735226a597c1b4363.tar.xz
ipmi: Add virtual/phosphor-ipmi-fru-hostfw-config
This virtual provides a configuration file that describes host firmware implementation details to ipmi-fru-parser. Add a recipe that provides the sample that comes with ipmi-fru-parser. Add a recipe for Hostboot on OpenPower systems. Set the default provider to the example. Set the default on OpenPOWER systems to the hostboot recipe. Change-Id: Iff56c5c0c2ea8aec7ecaa5a5d981da6f88a894f2 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/phosphor-ipmi-fru.bbclass1
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb19
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc9
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-phosphor/classes/phosphor-ipmi-fru.bbclass b/meta-phosphor/classes/phosphor-ipmi-fru.bbclass
new file mode 100644
index 000000000..d76bbc699
--- /dev/null
+++ b/meta-phosphor/classes/phosphor-ipmi-fru.bbclass
@@ -0,0 +1 @@
+hostfw_datadir="${datadir}/phosphor-ipmi-fru/hostfw"
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
new file mode 100644
index 000000000..aca1d0aab
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-hostfw-config-example-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Sample hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+require phosphor-ipmi-fru.inc
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ DEST=${D}${hostfw_datadir}
+ install -d ${DEST}
+
+ # TODO: copy example hostfw yaml to ${DEST}/config.yaml
+ # install fru-types.yaml ${DEST}/config.yaml
+}
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index 1740c7e5f..221e96094 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -33,5 +33,14 @@ PREFERRED_PROVIDER_virtual/obmc-wsgihost ?= "phosphor-gevent"
# the phosphor-ipmi-fru build process in the native sysroot.
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config ?= "phosphor-ipmi-fru-config-example-native"
+# virtual/phosphor-ipmi-fru-hostfw-config
+#
+# The phosphor-ipmi-fru application is data-driven and requires an input
+# mapping of how the host firmware reports inventory via IPMI.
+# This virtual is a native recipe that provides that mapping by installing
+# configuration files in the format and native sysroot location expected by
+# the phosphor-ipmi-fru build process.
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-hostfw-config ?= "phosphor-ipmi-fru-hostfw-config-example-native"
+
OBMC_DBUS_PATH_ROOT ?= "/xyz/openbmc_project"
OBMC_DBUS_IFACE_ROOT ?= "xyz.openbmc_project"