summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-09-19 04:01:41 +0300
committerBrad Bishop <bradleyb@us.ibm.com>2015-09-21 16:35:16 +0300
commit66c8eb0811d6857a66101745b3535729e78cffb4 (patch)
treeb30476e2acfb905e530238f8e67365f9d3231953 /meta-phosphor
parent3609840037f4056044e9e3d20e19a0182baca1da (diff)
downloadopenbmc-66c8eb0811d6857a66101745b3535729e78cffb4.tar.xz
Fix compile/link cmdlines in sample Makefile
Input object files were after --as-needed resulting in no DT_NEEDED tags
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
index b8f103da8..8ca27e4f4 100644
--- a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-fan/files/Makefile
@@ -6,9 +6,9 @@ INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
LIBS += $(shell pkg-config --libs $(DEPPKGS))
%.o : %.c
- $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
+ $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
$(EXE): $(OBJS)
- $(CC) $(LDFLAGS) $(LIBS) $^ -o $@
+ $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
clean:
rm -f $(OBJS) $(EXE) *.o *.d
distclean: clean