summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-27 05:30:17 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-01 22:50:23 +0300
commit9267362c97ebd474d9db37b4515f3f011f1ea457 (patch)
tree9d0ffe3c44974492a58df2fa8b54c94756576cb6 /meta-phosphor
parent038b44be9a95f0298243cbdcaa99aeed5fa7db2c (diff)
downloadopenbmc-9267362c97ebd474d9db37b4515f3f011f1ea457.tar.xz
Add missing pkgconfig dependencies
A number of skeleton recipes were missing pkgconfig dependencies. Exposed by Yocto 2.3 per-recipe sysroots feature. Change-Id: I514a95d08e199b395355341fec586b2af11428b5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb1
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb1
4 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
index 501f54abc..60bc87616 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/obmc-control-fan.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-sdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
RDEPENDS_${PN} += "libsystemd"
SKELETON_DIR = "fanctl"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
index c425027bf..f42bef443 100644
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
@@ -6,6 +6,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
SKELETON_DIR = "flashbios"
DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb
index d3d129048..e70c35474 100644
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-op-flasher.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "A BMC/BIOS flashing utility for use on OpenPOWER system."
PR = "r1"
inherit skeleton-gdbus
+inherit pkgconfig
DEPENDS += "pflash"
RDEPENDS_${PN} += "pflash"
diff --git a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
index 1842697e3..a4dba77f0 100644
--- a/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/host/obmc-op-control-host.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+inherit pkgconfig
PROVIDES += "virtual/obmc-host-ctl"
RPROVIDES_${PN} += "virtual-obmc-host-ctl"