summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrendan Higgins <brendanhiggins@google.com>2018-02-07 01:26:24 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-09 05:40:35 +0300
commita2efc8fd42ef76fc486b83a0b6a622bbbb5d26df (patch)
tree09a81f5039f22ea23aab3c663e13175034528bb4 /meta-phosphor
parent01e6b17936d00bcb0d3547873c557732abff1b80 (diff)
downloadopenbmc-a2efc8fd42ef76fc486b83a0b6a622bbbb5d26df.tar.xz
u-boot-fw-utils: Fix mtd-paritions failure
u-boot-fw-utils_%.bbappend was not working with all BSPs. In some cases it was unable to find 76-mtd-partitions.rules. This change uses a relative path that can always be found. Change-Id: Id5f88c3985d4feba5ac733e649107f1fa1498eb7 Tested: Built and verified mtd-paritions rule Signed-off-by: Brendan Higgins <brendanhiggins@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
index 6f9c5e69e..03b1a76d8 100644
--- a/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
+++ b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://76-mtd-partitions.rules"
+SRC_URI_append = " file://76-mtd-partitions.rules"
do_install_append() {
install -d ${D}/${base_libdir}/udev/rules.d/
- install ${WORKDIR}/76-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d/
+ install ${WORKDIR}/76-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d/
}