summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-10-30 21:58:11 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-10-30 21:58:11 +0300
commitaadbbe8ec40323c043edfd8e274bcdb85c53c6f8 (patch)
tree4cc7d787d8357444a777d349169e37a0061aefe7 /meta-phosphor
parentb2d7e0683b0fa5c5d7525b8adf7bbe9950e9bc68 (diff)
parent1182185041ea1d82d14b01fcc53574bf444fae00 (diff)
downloadopenbmc-aadbbe8ec40323c043edfd8e274bcdb85c53c6f8.tar.xz
Merge pull request #49 from bradbishop/network
Enable DHCP
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd/default.network4
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend8
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd/default.network b/meta-phosphor/common/recipes-core/systemd/systemd/default.network
new file mode 100644
index 000000000..c75c3d60d
--- /dev/null
+++ b/meta-phosphor/common/recipes-core/systemd/systemd/default.network
@@ -0,0 +1,4 @@
+[Match]
+Name=eth*
+[Network]
+DHCP=ipv4
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index b0cf90639..680595cb4 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -1 +1,9 @@
PACKAGECONFIG += "networkd"
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI += "file://default.network"
+
+FILES_${PN} += "${libdir}/systemd/network/default.network"
+
+do_install_append() {
+ install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
+}