summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-07-20 00:07:22 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-23 20:30:14 +0300
commit5bcb867763ca94dc55661d0f5ffdb7cd49057db9 (patch)
tree0a73ba1e640ab9a732800971364e5cb2aa0c8c5c /meta-phosphor
parent0f549e6ee23230f7b7bc0a81a0354a10eb6627cd (diff)
downloadopenbmc-5bcb867763ca94dc55661d0f5ffdb7cd49057db9.tar.xz
meta-phosphor: ipmi: flash: add layout options
The library will support by default a few flash options: the host bios, a static layout bmc image, and later a ubi-tarball approach. Other options later will include tying into bmc-code-mgmt allowing static tarballs, etc. (From meta-phosphor rev: ba602d9b0302743ab7c2685728ccf0ff899ade9c) Signed-off-by: Patrick Venture <venture@google.com> Change-Id: Iaa8d40994bc1f08eca3a3bc02f1d73ab8ff2896b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 3bf7ca7d8..ed7afff68 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -22,6 +22,10 @@ PACKAGECONFIG ?= "cleanup-delete"
PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
# If using static-layout, reboot-update is a good option to handle updating.
PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
+
+# Default options for supporting various flash types:
+PACKAGECONFIG[static-bmc] = "--enable-static-layout, --disable-static-layout"
+PACKAGECONFIG[ubitar-bmc] = "--enable-tarball-ubi, --disable-tarball-ubi"
PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
# Hardware options to enable transmitting the data from the host.