summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-06-12 19:37:12 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-16 23:42:25 +0300
commit61a11a921b253b5db50b4aed0394b3aa252046bd (patch)
tree2f12ee4c274cb48812434d1d452aead392cb9c8b /meta-phosphor
parent27a85412698c950b71b38553e32e31f368271084 (diff)
downloadopenbmc-61a11a921b253b5db50b4aed0394b3aa252046bd.tar.xz
meta-phosphor: define packagegroup for target YAML providers
As part of the transition away from packages with dual native/target variants where the native variant supplies YAML, add a packagegroup to contain all of the YAML-only packages. (From meta-phosphor rev: 9c39fb1e0cd3de5df55bfaa10e8daba591ff402b) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I8c7e09f040e90d599903c1923effbf51c259dab6 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
new file mode 100644
index 000000000..783ce40ce
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor OpenBMC - YAML Providers"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+# This is a packagegroup in name and principle but we do not want to inherit
+# from packagegroup.bbclass. The point of this packagegroup is to get the
+# sysroot populated with YAML files from the DEPENDS packages and if we inherit
+# the packagegroup bbclass this doesn't happen, because that bbclass `deltask`
+# a number that are required.
+# inherit packagegroup
+
+OBMC_YAML_PROVIDER_RECIPES += " \
+ phosphor-led-manager-yaml-provider \
+ phosphor-software-manager-yaml-provider \
+ "
+
+DEPENDS = "${OBMC_YAML_PROVIDER_RECIPES}"
+RDEPENDS_${PN} = "${OBMC_YAML_PROVIDER_RECIPES}"