summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-03 02:45:42 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-23 04:53:51 +0300
commit9ed709c3419cd8a3bd4c42229cce6e825072d05c (patch)
treecb424d298ed0b5f57d0396fa1cb657530a2c33fc /meta-phosphor
parent462f3ee7439f0bbebb3ee23f9d9b50c9e6a0ddae (diff)
downloadopenbmc-9ed709c3419cd8a3bd4c42229cce6e825072d05c.tar.xz
meta-phosphor: Add entity-manager recipe
This adds the entity-manager recipe to meta-phosphor. USE_OVERLAYS=0 because the overlay patch has not been added to the kernel. Tested-by: Compiled and ran entity-manager on the bmc. (From meta-phosphor rev: e8c0ec9e4686c14df084646c0fedf4474218767e) Change-Id: I25b119cde049cf409e43111450ffb9f39d0bf62c Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
new file mode 100644
index 000000000..b29372727
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Entity Manager"
+DESCRIPTION = "Entity Manager provides d-bus configuration data \
+and configures system sensors"
+
+SRC_URI = "git://github.com/openbmc/entity-manager.git"
+SRCREV = "b5e32c2396ac531f14d45d29dd4c6e159dcb1e0f"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
+ xyz.openbmc_project.FruDevice.service"
+
+PROVIDES += "virtual/phosphor-fans-sensor-inventory"
+DEPENDS = "boost \
+ i2c-tools \
+ nlohmann-json \
+ sdbusplus \
+ valijson"
+
+S = "${WORKDIR}/git/"
+inherit cmake systemd
+
+EXTRA_OECMAKE = "-DYOCTO=1 -DUSE_OVERLAYS=0"
+