summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2019-09-23 22:11:20 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-25 15:14:11 +0300
commit44cadefdf8e31d4a182dff48cae911d69cdcde3b (patch)
treed89da5ac76eb0c51ea62d76d17fc00ece5b5f1f1 /meta-phosphor
parentfcb74603386c272bd778470ead6e3794bf6fba5a (diff)
downloadopenbmc-44cadefdf8e31d4a182dff48cae911d69cdcde3b.tar.xz
phosphor-state-manager: srcrev bump 27115aec88..874051c8f7
Andrew Geissler (8): sysd_monitor: Initial application framework sysd_monitor: Parse command line parameters sysd_monitor: Create default monitoring json sysd_monitor: Parse json file(s) sysd_monitor: Handle default for errors to monitor sysd_monitor: Monitor and log errors sysd_monitor: Add systemd unit and required json Ignore code coverage files Add in appropriate dependencies to build the above commits. A separate commit will enable the new feature. (From meta-phosphor rev: f26fd90b0b6fe9f39704d3aa2ba7c572ecde9fda) Change-Id: I76ab84df762fe55bfea7848b7d78d0bcf5163cef Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 7aba09545..43ffa8c3c 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -15,6 +15,7 @@ STATE_MGR_PACKAGES = " \
${PN}-discover \
${PN}-host-check \
${PN}-reset-sensor-states \
+ ${PN}-systemd-target-monitor \
"
PACKAGE_BEFORE_PN += "${STATE_MGR_PACKAGES}"
ALLOW_EMPTY_${PN} = "1"
@@ -23,6 +24,7 @@ DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
SYSTEMD_PACKAGES = "${PN}-discover \
${PN}-reset-sensor-states \
+ ${PN}-systemd-target-monitor \
"
# The host-check function will check if the host is running
@@ -42,6 +44,8 @@ DEPENDS += "sdeventplus"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "libcereal"
+DEPENDS += "nlohmann-json"
+DEPENDS += "cli11"
FILES_${PN}-host = "${bindir}/phosphor-host-state-manager"
DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
@@ -66,6 +70,12 @@ SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-running@.service"
SYSTEMD_SERVICE_${PN}-reset-sensor-states += "phosphor-reset-sensor-states@.service"
+FILES_${PN}-systemd-target-monitor = " \
+ ${bindir}/phosphor-systemd-target-monitor \
+ ${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json \
+ "
+SYSTEMD_SERVICE_${PN}-systemd-target-monitor += "phosphor-systemd-target-monitor.service"
+
RESET_CHECK_TMPL = "phosphor-reset-host-check@.service"
RESET_CHECK_TGTFMT = "obmc-host-reset@{1}.target"
RESET_CHECK_INSTFMT = "phosphor-reset-host-check@{0}.service"
@@ -131,7 +141,12 @@ HOST_RST_RBT_ATTEMPTS_SVC_INST = "phosphor-reset-host-reboot-attempts@{0}.servic
HOST_RST_RBT_ATTEMPTS_SVC_FMT = "../${HOST_RST_RBT_ATTEMPTS_SVC}:${HOST_START_TGTFMT}.requires/${HOST_RST_RBT_ATTEMPTS_SVC_INST}"
SYSTEMD_LINK_${PN}-host += "${@compose_list_zip(d, 'HOST_RST_RBT_ATTEMPTS_SVC_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}"
+do_install_append() {
+ install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
+ install ${S}/phosphor-target-monitor-default.json ${D}${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json
+}
+
SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
-SRCREV = "27115aec886d69def59d18be7534d1156a9712ce"
+SRCREV = "874051c8f7fcdba499380beb6d232e6d80e52658"
S = "${WORKDIR}/git"