summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorSergey Solomin <sergey.solomin@us.ibm.com>2016-11-29 00:03:24 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-12-17 00:11:39 +0300
commitaac4adf831eebc74d97076e94125ebf5b6d5da48 (patch)
tree0b3ed6b9682a74a086e1a52b074854781611e3fd /meta-phosphor
parent370c28d56f3421d54d74cf23f89a184f3408b1ac (diff)
downloadopenbmc-aac4adf831eebc74d97076e94125ebf5b6d5da48.tar.xz
Add recipes for Witherspoon VCS workaround
Create vcs-workaround machine feature p9.inc Add new recipe vcs-pre-post.bb Add new recipe p9-vcs-workaround.bb Add new recipe start_host.bb Create preferred providers Create host control machine/distro/image feature Add dependencies Partially resolves openbmc/openbmc#647 Change-Id: I285cafc81afda20977fdf360ad8ad34d15e38685 Signed-off-by: Sergey Solomin <sergey.solomin@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/obmc-phosphor-image.bbclass2
-rw-r--r--meta-phosphor/common/recipes-phosphor/hosts/obmc-op-control-host.bb3
-rw-r--r--meta-phosphor/conf/distro/openbmc-phosphor.conf1
3 files changed, 6 insertions, 0 deletions
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 813b20d4f..31f99cf60 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -27,6 +27,7 @@ FEATURE_PACKAGES_obmc-settings-mgmt ?= "${@df_enabled('obmc-settings-mgmt', 'vir
FEATURE_PACKAGES_obmc-system-mgmt ?= "${@df_enabled('obmc-phosphor-system-mgmt', 'virtual-obmc-system-mgmt', d)}"
FEATURE_PACKAGES_obmc-host-ipmi ?= "${@cf_enabled('obmc-host-ipmi', 'virtual-obmc-host-ipmi-hw', d)}"
FEATURE_PACKAGES_obmc-logging-mgmt ?= "${@cf_enabled('obmc-logging-mgmt', 'virtual-obmc-logging-mgmt', d)}"
+FEATURE_PACKAGES_obmc-host-ctl ?= "${@cf_enabled('obmc-host-ctl', 'virtual-obmc-host-ctl', d)}"
# Install entire Phosphor application stack by default
IMAGE_FEATURES += " \
@@ -40,6 +41,7 @@ IMAGE_FEATURES += " \
obmc-system-mgmt \
obmc-host-ipmi \
obmc-logging-mgmt \
+ obmc-host-ctl \
ssh-server-dropbear \
"
diff --git a/meta-phosphor/common/recipes-phosphor/hosts/obmc-op-control-host.bb b/meta-phosphor/common/recipes-phosphor/hosts/obmc-op-control-host.bb
index dabc4a8a6..2b5e8b1dc 100644
--- a/meta-phosphor/common/recipes-phosphor/hosts/obmc-op-control-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/hosts/obmc-op-control-host.bb
@@ -5,6 +5,9 @@ PR = "r1"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service
+PROVIDES += "virtual/obmc-host-ctl"
+RPROVIDES_${PN} += "virtual-obmc-host-ctl"
+
SKELETON_DIR = "op-hostctl"
FMT = "org.openbmc.control.Host@{0}.service"
diff --git a/meta-phosphor/conf/distro/openbmc-phosphor.conf b/meta-phosphor/conf/distro/openbmc-phosphor.conf
index 22b6bc632..2355dca26 100644
--- a/meta-phosphor/conf/distro/openbmc-phosphor.conf
+++ b/meta-phosphor/conf/distro/openbmc-phosphor.conf
@@ -31,6 +31,7 @@ DISTRO_FEATURES = "\
obmc-host-ipmi \
obmc-mrw \
obmc-logging-mgmt \
+ obmc-host-ctl \
avahi \
${DISTRO_FEATURES_LIBC} \
"