summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2019-11-08 14:56:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-21 16:21:59 +0300
commit4c77c364c56783a56c51414aa59ee8222528fd55 (patch)
tree60308dfa21cce4d219c484ff6c71297d3fc1f9d8 /meta-phosphor
parent96f08eb465fa647af9779ceb20fb22670cd3dd92 (diff)
downloadopenbmc-4c77c364c56783a56c51414aa59ee8222528fd55.tar.xz
Remove priv-callback support
priv-callback is deprecated as this privilege is applicable only to IPMI modem callback, which will not be supported in OpenBmc. In order to avoid confusion with this role, the same has been deprecated. Refer https://gerrit.openbmc-project.xyz/#/c/openbmc/docs/+/26839/ Tested: 1. Verified user management works as expected 2. Verified existing user with priv-callback is rolled as no-acess user. (From meta-phosphor rev: 96e5ce1e16476e984fc805c99f01351e1e310e97) Change-Id: Ifea3986d9f4b55359138597ee0b6264870f1af0a Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
index 4ccf0c3a4..8a2971ccf 100644
--- a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
@@ -23,8 +23,8 @@ inherit useradd
USERADD_PACKAGES = "${PN} phosphor-ldap"
DBUS_PACKAGES = "${USERADD_PACKAGES}"
# add groups needed for privilege maintenance
-GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback "
-GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user; priv-callback "
+GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user "
+GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user "
DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
FILES_phosphor-ldap += " \