summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-07-11 04:56:17 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-07-14 05:33:02 +0300
commit73b88dd6649a68d44505af64787c8b9cd8a583d5 (patch)
tree0522078d7516ebf1cf213ef020ae581541aaed55 /meta-phosphor
parent87342b94e486adbd60a3f5046a88d64bec47cab8 (diff)
downloadopenbmc-73b88dd6649a68d44505af64787c8b9cd8a583d5.tar.xz
fans: Remove presence-example recipe
Replace the fan-presence example recipe with a re-usable "hardcoded" config recipe. Change-Id: I47fba19eb9243d123a44e448ebf4322593074e1c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb22
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml3
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-example-native.bb17
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc2
4 files changed, 26 insertions, 18 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
new file mode 100644
index 000000000..0eb38737c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
@@ -0,0 +1,22 @@
+# Provides the config file for the phosphor-fan-presence application.
+# The default config file is empty. To provide a real one,
+# append this recipe in a layer, add:
+# FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+# and provide a config file.
+
+SUMMARY = "Config file for phosphor-fan-presence"
+PR = "r1"
+
+inherit native
+inherit phosphor-fan
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-fan-presence-config"
+
+SRC_URI += "file://config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -D config.yaml ${D}${presence_datadir}/config.yaml
+}
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
new file mode 100644
index 000000000..15a10f409
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
@@ -0,0 +1,3 @@
+# This file is a stub. Consult
+# https://github.com/openbmc/phosphor-fan-presence
+# for file format description and examples.
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-example-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-example-native.bb
deleted file mode 100644
index 02e68167e..000000000
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-presence-example-native.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Phosphor Fan Presence Detection example data"
-PR = "r1"
-
-require phosphor-fan.inc
-
-inherit native
-inherit obmc-phosphor-license
-inherit phosphor-fan
-
-PROVIDES += "virtual/phosphor-fan-presence-config"
-
-S = "${WORKDIR}/git"
-
-do_install() {
- DEST=${D}${presence_datadir}
- install -D ${S}/presence/example/fan-detect.yaml ${DEST}/config.yaml
-}
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index 5a17df624..543413cd8 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -191,7 +191,7 @@ PREFERRED_PROVIDER_virtual/phosphor-logging-callouts ?= \
# configuration files in the format and native sysroot location expected by
# the phosphor-fan-presence build process in the native sysroot.
PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config ?= \
- "${@cf_enabled(d, 'obmc-mrw', 'phosphor-fan-presence-mrw-native', 'phosphor-fan-presence-example-native')}"
+ "${@cf_enabled(d, 'obmc-mrw', 'phosphor-fan-presence-mrw-native', 'phosphor-fan-presence-config-native')}"
# The phosphor-fan-control application is data driven and requires a YAML
# file to define the fans in the system.