summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2019-08-08 21:21:24 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-14 20:10:32 +0300
commitf85109289274a54b04e427ae2553932963b5c151 (patch)
treeebb6d873e3a1b9a1df1a841ae9db65f85c4b60f9 /meta-phosphor
parentb24a3e589e1a6eac0cb69d4c1ba2d1be36d1d2cb (diff)
downloadopenbmc-f85109289274a54b04e427ae2553932963b5c151.tar.xz
phosphor-logging: Add PEL PACKAGECONFIG
Create a PACKAGECONFIG option for phosphor-logging that allows one to enable the OpenPower PEL extension, which, when enabled, will create OpenPower Platform Event Log (PEL) format event logs for each OpenBMC event log. (From meta-phosphor rev: b1c8831ab098fdf2df6f096c27f40630f70e34fd) Change-Id: I592c073b6e7e03f106b9541ea937749a8995a7dc Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 39bef146b..a431b2c76 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -92,6 +92,11 @@ PACKAGECONFIG[install_scripts] = " \
--disable-install_scripts, ,\
"
+PACKAGECONFIG[openpower-pels] = " \
+ --enable-openpower-pel-extension, \
+ --disable-openpower-pel-extension, ,\
+ "
+
# Enable install_scripts during native and native SDK build
PACKAGECONFIG_add_class-native = "install_scripts"
PACKAGECONFIG_add_class-nativesdk = "install_scripts"