summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-10 05:57:35 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-14 15:18:55 +0300
commitfee4187da774de694d46ca5e65294099461e0030 (patch)
treee3828a31be35469c485a3f91ea9f4ede12f14041 /meta-phosphor
parent1c65850bff2d16b6790d956b9c6f2a6a7a76022b (diff)
downloadopenbmc-fee4187da774de694d46ca5e65294099461e0030.tar.xz
meta-phosphor: ipmid: enable EXTRA_OECONF override
Set the whitelist with the post-parse append operator, so ipmid bbappends can set EXTRA_OECONF directly. A simple example illustrates how this helps: foo.bb: BAR = "def" FOO = "abc ${BAR} foo.bbappend: FOO = "zyx" FOO would be "zyx" But if one has: foo.bb: BAR = "def" FOO = "abc" FOO_append = " ${BAR}" foo.bbappend: FOO = "zyx" FOO would be "zyx def" This is because bitbake parses recipes and bbappends in multiple passes - the second pass is when things like the _append operator and inline python are evaluated. for more reading: https://www.yoctoproject.org/docs/latest/bitbake-user-manual/bitbake-user-manual.html#override-style-operation-advantages (From meta-phosphor rev: bb60cffd406a8a413be0ce70b65d9b3447c95bbf) Change-Id: I2c9a4eaf65c815ebdf18ff158de75448837872b4 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 1438eaaae..314b70fd3 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -71,12 +71,14 @@ WHITELIST_CONF = " \
${S}/host-ipmid-whitelist.conf \
"
EXTRA_OECONF = " \
- WHITELIST_CONF="${WHITELIST_CONF}" \
SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
ENTITY_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/entity.yaml \
"
+EXTRA_OECONF_append = " \
+ WHITELIST_CONF="${WHITELIST_CONF}" \
+ "
S = "${WORKDIR}/git"