summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2020-05-06 21:14:28 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-16 23:42:28 +0300
commitb3f2bb8d832e4dc7873eaeef23be2fd38409d6f9 (patch)
tree4381026e746dc9f50bf386d4963c5b318cec4c02 /meta-phosphor
parentcdfe38fec85fdb177badd17ec810345c08d2cda9 (diff)
downloadopenbmc-b3f2bb8d832e4dc7873eaeef23be2fd38409d6f9.tar.xz
phosphor-software-manager: Move to meson
(From meta-phosphor rev: 2badcf923f4666c9c83842d0c0bc08132c6ef1c5) Change-Id: I124b014509e2370f65c24a1c3b3672932f156717 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/phosphor-software-manager-ubi-fs.bbclass12
-rw-r--r--meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb15
2 files changed, 7 insertions, 20 deletions
diff --git a/meta-phosphor/classes/phosphor-software-manager-ubi-fs.bbclass b/meta-phosphor/classes/phosphor-software-manager-ubi-fs.bbclass
index cc1ad3738..6ca1fb162 100644
--- a/meta-phosphor/classes/phosphor-software-manager-ubi-fs.bbclass
+++ b/meta-phosphor/classes/phosphor-software-manager-ubi-fs.bbclass
@@ -6,17 +6,9 @@ RDEPENDS_phosphor-software-manager-updater-ubi += " \
mtd-utils-ubifs \
"
-# Remove default configs
-EXTRA_OECONF_remove_df-obmc-ubi-fs += " \
- ACTIVE_BMC_MAX_ALLOWED=1 \
- MEDIA_DIR=/run/media \
-"
-
# Add ubi-fs configs
-EXTRA_OECONF_append_df-obmc-ubi-fs += " \
- ACTIVE_BMC_MAX_ALLOWED=2 \
- MEDIA_DIR=/media \
-"
+EXTRA_OEMESON += "-Dactive-bmc-max-allowed=2"
+EXTRA_OEMESON += "-Dmedia-dir='/media'"
SYSTEMD_SERVICE_phosphor-software-manager-updater-ubi += " \
obmc-flash-bmc-ubirw.service \
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
index d83945ea4..e0314c050 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-software-manager_git.bb
@@ -23,18 +23,17 @@ DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
# handles the rest.
SYSTEMD_PACKAGES = ""
-PACKAGECONFIG[verify_signature] = "--enable-verify_signature,--disable-verify_signature"
-PACKAGECONFIG[sync_bmc_files] = "--enable-sync_bmc_files,--disable-sync_bmc_files"
-PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout"
-PACKAGECONFIG[flash_bios] = "--enable-host_bios_upgrade"
+PACKAGECONFIG[verify_signature] = "-Dverify-signature=enabled, -Dverify-signature=disabled"
+PACKAGECONFIG[sync_bmc_files] = "-Dsync-bmc-files=enabled, -Dsync-bmc-files=disabled"
+PACKAGECONFIG[ubifs_layout] = "-Dbmc-layout=ubi"
+PACKAGECONFIG[flash_bios] = "-Dhost-bios-upgrade=enabled, -Dhost-bios-upgrade=disabled"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit obmc-phosphor-dbus-service
inherit python3native
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'phosphor-software-manager-ubi-fs', '', d)}
DEPENDS += " \
- autoconf-archive-native \
openssl \
phosphor-dbus-interfaces \
phosphor-logging \
@@ -46,10 +45,6 @@ RDEPENDS_${PN}-updater += " \
bash \
virtual-obmc-image-manager \
"
-EXTRA_OECONF += " \
- ACTIVE_BMC_MAX_ALLOWED=1 \
- MEDIA_DIR=/run/media \
-"
RPROVIDES_${PN}-version += " \
virtual-obmc-image-manager \