summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-07-14 21:41:21 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-15 18:46:53 +0300
commite38175414f5945bcf916f8793095e5859d34a0c9 (patch)
treeebec60236c84611d43a6d225c91d65d7744c55d0 /meta-phosphor
parent52b2330594715a5716db2951aea21a8e1adc3aa9 (diff)
downloadopenbmc-e38175414f5945bcf916f8793095e5859d34a0c9.tar.xz
create libopenbmc_intf.so link in rootfs
An upstream change removed a workaround that OpenBMC was depending on which created any missing symlinks in the rootfs. See the following for more details: https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=061eb6f501c6262266230919ef55ebf02a26abcd This caused the libopenbmc_intf.so link to no longer be created in /usr/lib/. This then caused applications like power_control.exe to no longer start with an error like this: Jul 12 23:26:15 witherspoon power_control.exe[367]: power_control.exe: error while loading shared libraries: libopenbmc_intf.so: cannot open shared object file: No such file or directory Long term the goal is to move away from power_control.exe and the skeleton repo in general. For now, just get us back to how things were with this patch. Tested: Verified link is back in witherspoon image and power_contro.exe started successfully. Resolves openbmc/openbmc#3677 (From meta-phosphor rev: 2642059cbd80660bd62e3d4ae7f0a1ac40967872) Change-Id: I111f407b34309cb98334f1f8e665269f0ed4277d Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
index 59692ecb8..85191c636 100644
--- a/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
+++ b/meta-phosphor/recipes-phosphor/skeleton/obmc-libobmc-intf_git.bb
@@ -14,6 +14,20 @@ SKELETON_DIR = "libopenbmc_intf"
SRC_URI += "file://gpio_defs.json"
+# Users of libopenbmc_intf use custom makefiles that do not
+# support the proper library version detection and linking.
+# Because of that, a link must be created within the
+# rootfs for applicaitons to use this library.
+# This next line tells bitbake to skip the check which
+# ensures no links are put in the rootfs
+INSANE_SKIP_${PN} += "dev-so"
+
+# Ensure the library is not in the dev package
+FILES_SOLIBSDEV = ""
+
+# Now add the link to the production package
+FILES_${PN} += "${libdir}/libopenbmc_intf.so"
+
do_install() {
oe_runmake install DESTDIR=${D}