summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-05-18 23:56:14 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-05-26 22:11:24 +0300
commitef047e2f899180e3fb72ba565abef459197fa60d (patch)
treee7582813214276ad6d7fdce6a042dc731da55bfc /meta-phosphor
parent74f3852056ec1b3e58c6040d2a9eb8438462037a (diff)
downloadopenbmc-ef047e2f899180e3fb72ba565abef459197fa60d.tar.xz
phosphor-networkd: Use meson instead of autotools
Change-Id: I7f4860405420eead896343a5dfee769b3781ba76 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb22
1 files changed, 9 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 0f235ace2..94090fbbf 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -6,7 +6,7 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
-inherit autotools pkgconfig
+inherit meson pkgconfig
inherit python3native
inherit systemd
@@ -14,7 +14,6 @@ SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "1e710d04a61092b45ff4ccd58656cb5cee3cba5b"
DEPENDS += "systemd"
-DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
DEPENDS += "sdeventplus"
DEPENDS += "phosphor-dbus-interfaces"
@@ -25,18 +24,15 @@ DEPENDS += "stdplus"
PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra"
UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"
-PACKAGECONFIG[uboot-env] = "--with-uboot-env,--without-uboot-env,,${UBOOT_ENV_RDEPENDS}"
-PACKAGECONFIG[default-link-local-autoconf] = "--enable-link-local-autoconfiguration,--disable-link-local-autoconfiguration,,"
-PACKAGECONFIG[default-ipv6-accept-ra] = "--enable-ipv6-accept-ra,--disable-ipv6-accept-ra,,"
-PACKAGECONFIG[nic-ethtool] = "--enable-nic-ethtool,--disable-nic-ethtool,,"
-PACKAGECONFIG[sync-mac] = "--enable-sync-mac,--disable-sync-mac,nlohmann-json,"
+PACKAGECONFIG[uboot-env] = "-Duboot-env=true,-Duboot-env=false,,${UBOOT_ENV_RDEPENDS}"
+PACKAGECONFIG[default-link-local-autoconf] = "-Ddefault-link-local-autoconf=true,-Ddefault-link-local-autoconf=false,,"
+PACKAGECONFIG[default-ipv6-accept-ra] = "-Ddefault-ipv6-accept-ra=true,-Ddefault-ipv6-accept-ra=false,,"
+PACKAGECONFIG[nic-ethtool] = "-Dnic-ethtool=true,-Dnic-ethtool=false,,"
+PACKAGECONFIG[sync-mac] = "-Dsync-mac=true,-Dsync-mac=false,nlohmann-json,"
S = "${WORKDIR}/git"
-SERVICE_FILE = "xyz.openbmc_project.Network.service"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+FILES_${PN} += "${datadir}/dbus-1/system.d"
-EXTRA_OECONF = " \
- SYSTEMD_TARGET="multi-user.target" \
-"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Network.service"