summaryrefslogtreecommitdiff
path: root/meta-quanta/conf/layer.conf
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-05-17 03:33:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-23 18:42:34 +0300
commit404ab0eb560e0d516908239f52577bf52ef694b4 (patch)
treebe2a856dabc4f668019dd5db00d6ff85b1184ef3 /meta-quanta/conf/layer.conf
parentf0b93bca90fdaa671adc371581380fbad2ea63bf (diff)
downloadopenbmc-404ab0eb560e0d516908239f52577bf52ef694b4.tar.xz
meta-quanta: conf bugfix: layer
Fix the quanta layer to be named "quanta-layer" to conform to expectations. Also add missing boilerplate code to add recipes from this layer. There are currently no recipes in this layer outside of within a machine specification, but the change will prevent future bugs. (From meta-quanta rev: 7cbfa54ecf5fb464dfd1a93090b9462261105f9c) Signed-off-by: Patrick Venture <venture@google.com> Change-Id: I1c0ac88ee4e502563ed89612657f230548d4b58d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta/conf/layer.conf')
-rw-r--r--meta-quanta/conf/layer.conf10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-quanta/conf/layer.conf b/meta-quanta/conf/layer.conf
index fb4c08315..6bc649299 100644
--- a/meta-quanta/conf/layer.conf
+++ b/meta-quanta/conf/layer.conf
@@ -1,9 +1,13 @@
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"
-BBFILE_COLLECTIONS += "quanta"
-BBFILE_PATTERN_quanta := "^${LAYERDIR}/"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "quanta-layer"
+BBFILE_PATTERN_quanta-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_quanta-layer = "thud warrior"
# Provide a variable that points the base of the quanta layer.
QUANTABASE = '${@os.path.normpath("${LAYERDIR}/")}'
-LAYERSERIES_COMPAT_quanta-layer = "thud warrior"