summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb')
-rw-r--r--meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb b/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
new file mode 100644
index 000000000..fd5819d42
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
@@ -0,0 +1,25 @@
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
+SRCREV = "ca2dc1bf7f34d517f0edc59dd3596c3a76c3d7a1"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit meson
+
+DEPENDS += " nlohmann-json"
+DEPENDS += " sdbusplus"
+DEPENDS += " sdeventplus"
+DEPENDS += " phosphor-dbus-interfaces"
+RDEPENDS_${PN} += " bash"
+
+FILES_${PN} = "${bindir}/read-margin-temp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 read-margin-temp ${D}${bindir}
+}
+