summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-08-03 08:39:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-06 01:09:00 +0300
commitbd21fb244289e1f8092c3c594f6be9cc10538b5b (patch)
treeeda2798103f4720d6d8ca2c2f235c2fb17a15d02 /meta-quanta/meta-common
parent7b402840881eb00acc73a7ddf095de3d5fd68547 (diff)
downloadopenbmc-bd21fb244289e1f8092c3c594f6be9cc10538b5b.tar.xz
meta-quanta: common: add "read-margin-temp" service
Add "read-margin-temp" service to meta-quanta/meta-common This daemon will read the temperatures of various sensors and calculate the worst thermal margin (From meta-quanta rev: a8f1a52fbaf2075f54e4cc8e2b3619172148e54f) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I79623132d6dbf84ef1646e61a5c2374db132ea48 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-common')
-rw-r--r--meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb b/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
new file mode 100644
index 000000000..bd2e75be7
--- /dev/null
+++ b/meta-quanta/meta-common/recipes-quanta/fans/read-margin-temp_git.bb
@@ -0,0 +1,26 @@
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
+SRCREV = "ca2dc1bf7f34d517f0edc59dd3596c3a76c3d7a1"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+inherit meson
+
+DEPENDS += " nlohmann-json"
+DEPENDS += " sdbusplus"
+DEPENDS += " sdbusplus-native"
+DEPENDS += " sdeventplus"
+DEPENDS += " phosphor-dbus-interfaces"
+RDEPENDS_${PN} += " bash"
+
+FILES_${PN} = "${bindir}/read-margin-temp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 read-margin-temp ${D}${bindir}
+}
+