summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-gbs/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorGeorge Hung <george.hung@quantatw.com>2020-05-21 13:59:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-05 02:40:38 +0300
commit5ccf3f257977e925c34031887d47f4279562d9c9 (patch)
tree46ba5d9d57892581633988510e4357392d83c176 /meta-quanta/meta-gbs/recipes-bsp/u-boot
parent32567be1f1213d62d69cc735f0b9a355c350040c (diff)
downloadopenbmc-5ccf3f257977e925c34031887d47f4279562d9c9.tar.xz
meta-quanta: gbs: add xml for igps and patch/dts for u-boot
1.XML: change the SPI speed to 19Mhz 2.U-boot: dts/pinctrl: add GBS dts/pinctrl support Nuvoton u-boot srcrev bump adb4ac1af3...6870e66f6b: https://gerrit.openbmc-project.xyz/c/openbmc/meta-nuvoton/+/34756 3.modify u-boot environment partiions offset for GBS (From meta-quanta rev: 705d71a8a0ee00f89f06c95601aa1375a440611a) Signed-off-by: George Hung <george.hung@quantatw.com> Change-Id: I47960d63b557f6de1c9d84b290094253f4ffba58 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-gbs/recipes-bsp/u-boot')
-rw-r--r--meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config24
-rw-r--r--meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend6
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
new file mode 100644
index 000000000..0c384273f
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
@@ -0,0 +1,24 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd2 0x0000 0x40000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
+
+# VFAT example
+#/boot/uboot.env 0x0000 0x4000
diff --git a/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 000000000..8b66271a5
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://fw_env.config"
+
+do_install_append_gbs() {
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}